ニュース
» 2007年01月17日 10時10分 UPDATE

Googleサービスにcookie盗難の脆弱性

Googleの脆弱性が原因で、攻撃者がユーザーのcookieを盗んでGoogle Docs & Spreadsheetsやメールにアクセスできる状態になっていた。

[ITmedia]

 Googleサーバにクロスサイトスクリプティングの脆弱性が存在し、ユーザーのcookieを盗むことができてしまう問題が報告された。Googleでは既に脆弱性を修正済みだという。

 この問題は、ドイツのフィリップ・レンセン氏が運営する「Google Blogoscoped」のブログで報告された。攻撃者はGoogle.comを使った長いURLにユーザーを誘導してcookieデータを入手。これを使ってGoogle Docs & Spreadsheetsにアクセスして内容を改ざんしたり、ユーザーの電子メールの件名や検索履歴などを参照できてしまう状態になっていたという。

 レンセン氏は最新版のFirefox 2でこの問題を再現。3行のPHPスクリプトを作成して自分のサーバにアップロードし、問題のGoogle URLを使ってcookieを盗むことができてしまったと報告している。

 この問題は、特定のGoogleサービスのアップデートと関係があると同氏は指摘。HTMLインジェクションに対する適切な防御が講じられていないため、JavaScriptを使ってcookieのデータを外部に受け渡すことが可能になっていたという。

 その後この問題は修正され、Google側でHTMLインジェクションに対する適切な防御が講じられたとブログでは伝えている。

Copyright© 2016 ITmedia, Inc. All Rights Reserved.

Loading

ピックアップコンテンツ

- PR -

マーケット解説

- PR -